Supporto » Fixing WordPress » Visualizzazione sbagliata sito Web

  • Risolto xuki87

    (@xuki87)


    Buongiorno a tutti,

    ho dei problemi di visualizzazione del mio sito internet raggiungibile su parajse.com..
    Ho modificato .htaccess (senza tenere il backup del file perche credevo che updraftplus backup mi faceva il backup anche di questo file) e adesso non riesco piu a vedere il mio sito in modo giusto.
    Se inserisco il file .htaccess normale (quello che lo scarico da wordpress) comunque il problema non si risolve. Anche disattivando tutti i plugin il problema non si risolve.

    Sono abbastanza disperato.

    P.S: Posso dare un account di accesso a qualcuno se vuole vedere tutto quello che ho combinato!!!

    Grazie

    • Questo topic è stato modificato 7 anni, 8 mesi fa da xuki87.
    • Questo topic è stato modificato 7 anni, 8 mesi fa da xuki87.
Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Buongiorno @xuki87

    I membri del forum, inclusi autori di temi e plugin, non devono mai richiedere privilegi di accesso amministrativi o FTP a server, MySQL, o istallazioni WordPress.
    tratto dal regolamento del forum

    Qual’è stato l’evento che ha causato questo problema?

    Lo spostamento da un server ad un altro o cosa?

    E’ stato usato un file .htaccess generico come questo?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    E’ stato chiesto all’hosting se sono state cambiate le regole di Apache o del webserver attivo?

    Chi ha creato la discussione xuki87

    (@xuki87)

    Buongiorno,

    la ringrazio intanto per la risposta.
    Credo che la causa è proprio il file .htaccess (in questo momento sto utilizzando quello generico da te indicato).
    Non è in corso nessun spostamento da qualche server e dal hosting mi dicono che non è cambiato niente.

    Stavo configurando W3 total plugin e ho attivato la compressione GZIP compression. Credo di aver attivato sia la funzione sul plugin che aggiungendo questo codice su .htaccess

    # compress text, html, javascript, css, xml:
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddType x-font/otf .otf
    AddType x-font/ttf .ttf
    AddType x-font/eot .eot
    AddType x-font/woff .woff
    AddType image/x-icon .ico
    AddType image/png .png

    Da quel momento è successo qualcosa di strano. Da principiante non ho salvato il file (anche perche credo che avevo già il backup di tutti i file) ma sono andato a rimettere .htaccess generico e ho disinsitallato il plugin w3 total. Però la situazione non è cambiata. Adesso ho installato il plugin ma niente di nuovo (è sempre attivo HTTP GZIP compression) e se disattivo e confermo resta comunque attivo e la situazione non cambia.

    Chi ha creato la discussione xuki87

    (@xuki87)

    Adesso ho disattivato tutti i plugin ma il problema persiste!

    Chi ha creato la discussione xuki87

    (@xuki87)

    Ho notato che anche quando apro i miei post per modificarli (dal pannello di admin) o vado a vedere le immagini già caricate ho problemi. Foto. Sapete a cosa può essere dovuto? Anche nel pannello di admin non vedo le immagini (copertine dei temi; immagini caricate, immagini all’interno dei post etc)

    Ho attivato anche la tema base di wordpress, ho disattivato tutti i plugin e adesso ho .htaccess consigliato da wordpress.

    Sembra anche che non accede alle immagini: foto

    • Questa risposta è stata modificata 7 anni, 8 mesi fa da xuki87.
    Moderatore Rosetta Facciolini

    (@ramthas)

    Web Manager

    Ciao @xuki87
    controlla i permessi alle cartelle, può essere che siano stati in qualche modo modificati (forse dopo un aggiornamento), a quel punto potrebbe essere necessario “ripristinare i permessi” via ftp o server chiedendo al tuo fornitore

    Potresti anche provare a cancellare il file .htaccess (prima però eseguire il backup del file .htaccess originale) che non abbia qualche errore di configurazione…

    Moderatore Rosetta Facciolini

    (@ramthas)

    Web Manager

    ps. l’errore 404 (http://imgur.com/a/ALcZP): significa che il server non è riuscito a trovare la risorsa

    Chi ha creato la discussione xuki87

    (@xuki87)

    Ho fatto un restore totale del sito dal mio hosting e adesso è tornato tutto nella normalità.

    grazie a tutti

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Il topic ‘Visualizzazione sbagliata sito Web’ è chiuso a nuove risposte.