Supporto » Varie ed eventuali » XAMMP non carica post, pagine media

  • Buonasera,
    ho scaricato il sito da remoto a locale.
    Plugins e temi si sono scaricati.
    Post, pagine e media no.
    Grazie del supporto

Stai visualizzando 13 risposte - dal 1 al 13 (di 13 totali)
  • Ciao @orsocapo ,
    Vorrei chiederti come hai eseguito lo scarico da remoto a locale e se ci sono messaggi di errore.
    In particolare, essendo su XAMPP è molto facile leggere i file di log del server.

    Sempre su XAMPP immagino che avrai attivato xDebug.

    un saluto.

    Ciao Luca21,
    grazie della risposta.
    Sul log in effetti c’è una serie di segnalazioni
    …ehm…attivato per debug non so dirti

    Questo è il log relativo a SQL perchè ho la sensazione che l’errore sia qui
    InnoDB: using atomic writes.
    2020-11-22 12:32:21 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2020-11-22 12:32:21 0 [Note] InnoDB: Uses event mutexes
    2020-11-22 12:32:21 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
    2020-11-22 12:32:21 0 [Note] InnoDB: Number of pools: 1
    2020-11-22 12:32:21 0 [Note] InnoDB: Using SSE2 crc32 instructions
    2020-11-22 12:32:21 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
    2020-11-22 12:32:21 0 [Note] InnoDB: Completed initialization of buffer pool
    2020-11-22 12:32:21 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=4172087
    2020-11-22 12:32:21 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
    2020-11-22 12:32:21 0 [Note] InnoDB: Removed temporary tablespace data file: “ibtmp1”
    2020-11-22 12:32:21 0 [Note] InnoDB: Creating shared tablespace for temporary tables
    2020-11-22 12:32:21 0 [Note] InnoDB: Setting file ‘C:\xampp\mysql\data\ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …
    2020-11-22 12:32:21 0 [Note] InnoDB: File ‘C:\xampp\mysql\data\ibtmp1’ size is now 12 MB.
    2020-11-22 12:32:21 0 [Note] InnoDB: Waiting for purge to start
    2020-11-22 12:32:21 0 [Note] InnoDB: 10.4.16 started; log sequence number 4172096; transaction id 2086
    2020-11-22 12:32:21 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
    2020-11-22 12:32:21 0 [Note] Plugin ‘FEEDBACK’ is disabled.
    2020-11-22 12:32:21 0 [Note] Server socket created on IP: ‘::’.
    2020-11-22 12:32:21 0 [Note] InnoDB: Buffer pool(s) load completed at 201122 12:32:21

    Ciao @orsocapo ,

    …ehm…attivato per debug non so dirti

    xdebug è un modulo apache e si attiva dal php.ini (lo dico per un lettore occasionale di questo post).
    Non importa, su xampp dovrebbe essere attivato d’ufficio.

    Però non hai detto come hai fatto la migrazione remoto > locale e nemmeno i messaggi di errore che hai trovato nei log.
    La lista che hai appena postato è solo l’elenco di operazioni compiute dal db, direi.
    Un saluto.

    Scusami per l’incompletezza della mia risposta.
    La migrazione l’ho fatta tramite FTP scaricando tutte le cartelle da remoto e poi inserendole nella cartella htdocs.
    Ho modificato il file wp_config
    Poi ho scaricato il DB e ricaricato sul DB di XAMMP
    I messaggi del log sono questi:
    [Sun Nov 22 12:32:20.648819 2020] [ssl:warn] [pid 14788:tid 648] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Nov 22 12:32:20.710567 2020] [core:warn] [pid 14788:tid 648] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten — Unclean shutdown of previous Apache run?
    [Sun Nov 22 12:32:20.717565 2020] [ssl:warn] [pid 14788:tid 648] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Nov 22 12:32:20.823139 2020] [mpm_winnt:notice] [pid 14788:tid 648] AH00455: Apache/2.4.46 (Win64) OpenSSL/1.1.1h PHP/7.4.12 configured — resuming normal operations
    [Sun Nov 22 12:32:20.823139 2020] [mpm_winnt:notice] [pid 14788:tid 648] AH00456: Apache Lounge VC15 Server built: Oct 3 2020 12:58:33
    [Sun Nov 22 12:32:20.823139 2020] [core:notice] [pid 14788:tid 648] AH00094: Command line: ‘c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache’
    [Sun Nov 22 12:32:20.826138 2020] [mpm_winnt:notice] [pid 14788:tid 648] AH00418: Parent: Created child process 12304
    [Sun Nov 22 12:32:21.235170 2020] [ssl:warn] [pid 12304:tid 660] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Nov 22 12:32:21.294174 2020] [ssl:warn] [pid 12304:tid 660] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Nov 22 12:32:21.337178 2020] [mpm_winnt:notice] [pid 12304:tid 660] AH00354: Child: Starting 150 worker threads.
    [Sun Nov 22 12:37:29.884824 2020] [php7:notice] [pid 12304:tid 1900] [client ::1:62164] WordPress errore sul database Table doesn’t exist per la query \r\n\t\t\tSELECT COUNT(donation_id)\r\n\t\t\tFROM wpwq_give_donationmeta\r\n\t\t\tWHERE meta_key=’_give_payment_gateway’\r\n\t\t\tAND meta_value LIKE ‘%stripe%’ fatta da activate_plugins, activate_plugin, do_action(‘activate_give/give.php’), WP_Hook->do_action, WP_Hook->apply_filters, Give->install, give_install, give_run_install, do_action(‘give_upgrades’), WP_Hook->do_action, WP_Hook->apply_filters, give_do_automatic_upgrades, give_v270_upgrades, referer: http://localhost//wp-admin/plugins.php?plugin_status=all&paged=1&s

    • Questa risposta è stata modificata 1 settimana, 5 giorni fa da orsocapo.

    Ciao @orsocapo ,

    La migrazione l’ho fatta tramite FTP scaricando tutte le cartelle da remoto e poi inserendole nella cartella htdocs.
    Ho modificato il file wp_config
    Poi ho scaricato il DB e ricaricato sul DB di XAMMP

    Una migrazione “manuale”. Richiede ulteriori accorgimenti.
    I vecchi link devono essere modificati perché adesso devono puntare a “localhost/qualcosa”.
    Inoltre il protocollo https non l’unsi più in locale.

    Per quanto riguarda i link ci sono varie guide in rete, questa è quella ufficiale:
    https://wordpress.org/support/article/moving-wordpress/

    C’è anche un plugin:
    https://wordpress.org/plugins/velvet-blues-update-urls/

    Per quanto riguarda https -> http c’è da modificare ulteriormente wp-config.php e, giusto per andare sul sicuro, anche un paio di righe di una tabella del db, non ricordo quale, spiacente.

    Grazie Luca21,
    http sono riuscito a modificarlo e il sito in locale esce perfettamente. L’unico problema è proprio legato all’assenza dei post etc.
    ora vedo di capirci qualcosa perchè mi sembra abbastanza complicato.
    Grazie ancora e buona serata

    Ciao @orsocapo,
    il database l’hai esportato tramite un DUMP, generando un file sql?
    Se è così, una volta importato su quello locale, dovresti avere a livello DB tutti i tuoi post e pagine. Puoi controllarlo intanto aprendo PhpMyAdmin e andando nella tabella wp_posts: lì puoi fare un check veloce.

    Inoltre, dai log che hai postato, sembra che qualche plugin manchi o non sia attivato. Considera che alcuni generano delle tabelle custom all’interno del database; dovrai aver importato anche quelle, altrimenti avrai dei problemi.

    Facci sapere.

    Ho esportato il Database dal mio provider generando un file .sql
    Poi l’ho caricato nel DB locale.
    In effetti i plugin non erano attivati ma poi li ho attivati ma il problema non è legato a quello
    Grazie

    Ok @orsocapo. Se ritieni che questo thread sia risolto, puoi marcarlo come tale.
    Grazie!

    Non è risolto ma credo che non se ne esca quindi mi arrendo.
    Grazie a tutti

    • Questa risposta è stata modificata 1 settimana, 4 giorni fa da orsocapo.
    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve orsocapo ,

    se il problema non è risolto il topic rimane non risolto per permettere di trovare un’eventuale soluzione.

    Come evidenziato da Luca il posto più completo dove guardare le istruzioni su come si sposta/copia una installazione WP è:

    https://wordpress.org/support/article/moving-wordpress/

    Il consiglio è di provare ad utilizzare anche un altro plugin come https://it.wordpress.org/plugins/all-in-one-wp-migration/

    Buongiorno Cristiano Zanca,
    grazie per l’aggiornamento.
    Avevo avuto un momento di depressione perchè ho cercato molto senza riuscire a trovare soluzioni.
    Ora proverò con questo suggerimento e ringrazio tutti gli amici che mi stanno dando una mano sul forum.
    Appena verifico posto il risultato e spero di poter mettere un “risolto” serio!

Stai visualizzando 13 risposte - dal 1 al 13 (di 13 totali)
  • Devi essere collegato per rispondere a questo topic.