Alessandro Lin
Risposte nei forum create
-
Forum: Funzionalità = Plugin
In risposta a: Problema redirect in homepage (tutte le pagine del sito!!!)Penso che non sia un malware. Le pagine sul sito funzionano bene, allora dev’essere una cosa del motore di ricerca. Hai provato con altri? Duckduckgo, Bing ecc?
Ho trovato solo una cosa. Uno degli endpoint delle Rest Api di WP, che sono indicate nella Head del sito, è malformato. Precisamente questo: https://artofhair.it/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fartofhair.it%2F&format=xml
Però dubito che sia la ragione per cui Google indirizza in realtà solo la home page del sito.
—
Forum: Installazione e Aggiornamento
In risposta a: errore dopo aggiornamento FATAL ERRORBuongiorno @webepc,
Devo essermi espresso male.
Non ci sono problemi con php 8.3.0. L’ultimo WordPress è perfettamente compatibile con php 8.3.0. Verificato su un sito live, in produzione. Funziona bene.
Stiamo uscendo credo. Se l’argomento interessa apriremo una discussione nuova.
Forum: Installazione e Aggiornamento
In risposta a: errore dopo aggiornamento FATAL ERRORPiccola informazione, magari interessa a qualcuno.
Su un sito ho installato php 8.3.0
Ci sono solo i plugin più comuni comunque funziona bene. Sembra anche un filino più veloce di prima.
—
Forum: Aspetto = Temi
In risposta a: Aumentare dimensioni del logo in tema NewsmagSi può provare con un css leggermente diverso:
img.td-retina-data.td-retina-version { width: 725px !important; height: 250px !important; }Questa regola css, inserita nella pagina con gli strumenti di sviluppo del browser che sono sempre disponibili, aumenta effettivamente la dimensione del logo e non mi sembra di vedere problemi di risoluzione dell’immagine. Dovrebbe funzionare anche inserendola nell’editor css della dashboard del sito.
—
Forum: Fixing WordPress
In risposta a: WP-appena installato plugin errorNon c’è di che. Fai sapere.
Forum: Fixing WordPress
In risposta a: WP-appena installato plugin errorinstallato tramite hosting
Presumo che significhi che hai installato tramite il pannello dell’hosting.
Si può provare allora una installazione manuale. A volte, molto raramente, i pannelli installano delle versioni di sviluppo che non sono ancora mature. L’installazione manuale è semplice. Bisogna creare prima un database, scaricare l’ultima versione stabile di wp – 6.4.1 – adesso, caricarla sulla cartella radice del sito, quella che in genere si apre quando fai un accesso ftp con le credenziali fornite dal fornitore e poi seguire uno dei tutorial per “installazione di wp in 5 minuti”. Ne trovi tantissimi digitando su un qualsiasi motore di ricerca “wordpress 5 minute install”.
Prima però sarebbe meglio controllare le specifiche del php e del database che trovi nel “Site Health” sezione info.
Il php minimo è il 7.4 ma è meglio se c’è una versione del php 8. Con alcuni settaggi, ti elenco i principali.
PHP max input variables 1000
PHP time limit 60
PHP memory limit 128M
PHP memory limit (only for admin screens) 256M
Max input time 60
Upload max filesize 100M
PHP post max size 100MPoi il database. I più critici sono il charset e il collate.
Database charset utf8mb4
Database collation utf8mb4_unicode_520_ci o equivalente
Se, dopo tutto questo lavoro, ancora non funziona, siccome WP 6.4.1 sembra funzionare bene nel mondo, la causa dell’errore si inizia a pensare che sia il server, memoria scarsa o sovraffollato.
Forum: Installazione e Aggiornamento
In risposta a: Errore irreversibileNon c’è di che.
Magari se modifichi il db potresti scrivere cos’hai fatto e cosa è successo.
–
Forum: Installazione e Aggiornamento
In risposta a: Errore irreversibileEcco, quale plugin usi? Ce ne sono parecchi. Su un sito di prova me ne sono trovati 2, installati tempo fa.
** Woody code snippets
https://wordpress.org/plugins/insert-php/*** WPCode Lite
https://wordpress.org/plugins/insert-headers-and-footers/Entrambi fanno più o meno le stesse cose. Entrambi registrano gli snippets nel database.
Per risolvere il problema potresti installare un plugin diverso da quello che hai dovuto rimuovere a causa dell’errore nel frammento di codice.
Si potrebbe anche cancellare / modificare lo snippet sbagliato che è registrato nel database ma è una operazione un po’ delicata e sarebbe meglio fare prima un backup del sito. La tabella usata dai due plugin che ho installato io è la “options” del database, quella solita. Con phpmyadmin (o applicazione equivalente) si trova la riga interessata e si fa la correzione.
–
Forum: Sviluppare con WordPress
In risposta a: WP_Query su tassonomie di un pluginCi vuole un po’ di pazienza.
Intanto sistemare la sintassi del frammento, altrimenti non può funzionare.
Poi vedere se davvero risulta qualcosa dalla query. Un modo abbastanza facile e “casereccio”, se il contenuto è uno dei soliti, potrebbe essere inserire una istruzione (provvisoria) così:
file_put_contents('test.txt', json_encode($loop));esamini successivamente il file ‘test.txt’ e vedi che cosa c’è dentro.
Se tutto va bene scrivi il codice necessario ad estrarre in maniera utilizzabile i dati da $loop.
Non posso farlo io dal forum. Buon lavoro 🙂
Forum: Sviluppare con WordPress
In risposta a: WP_Query su tassonomie di un pluginForse può servire. Ad un esame superficiale, se carico il codice su Visual Studio Code ci sono errori.
In particolare questo blocco va riesaminato:
if( $loop->have_posts() ) : while( $loop->have_posts() ) : $loop->the_post();Possibili errori di sintassi. Cosa succede poi con $loop->the_post(); ???
—