Risposte al Forum Create

Stai visualizzando 6 risposte - dal 1 al 6 (di 6 totali)
  • Segnalazione di problemi di compatibilità per i temi
    Questa sezione contiene un elenco di temi degni di nota (ad alto impatto / grande) con problemi di compatibilità e le loro risposte quando disponibili.

    Nessuno riportato fino ad ora.

    Segnalazione di problemi di compatibilità dei plugin
    Questa sezione contiene un elenco di plugin degni di nota (ad alto impatto / grande) con problemi di compatibilità e le loro risposte quando disponibili.

    Nessuno riportato fino ad ora.

    Bug segnalati
    I bug che sono stati segnalati riguardo questa versione di WordPress, con link ai ticket per ulteriori followup, saranno elencati qui.

    • Non riesco ad aggiornare i temi – Alcuni sistemi potrebbero avere qualche problema con un nuovo file introdotto con WordPress 5.2. Se possibile, prova ad aumentare l’opzione “Max Execution time” sul tuo server (o chiedi al tuo host). Maggiori dettagli saranno disponibili nel ticket #47186.
    • Dopo un accesso, la disconnessione si blocca o genera un messaggio di errore. Questo è un bug e verrà risolto nella 5.2.4. Vedi https://core.trac.wordpress.org/ticket/47980

    Non è un bug
    Gli utenti potranno trovare scenari degni di nota e ricorrenti che non sono in realtà bug, ma piuttosto cambiamenti o nuovi comportamenti.

    Non sono in grado di effettuare l’aggiornamento: l’aggiornamento non può essere installato perché WordPress 5.2 richiede PHP 5.6.20 o più alto.
    Con WordPress 5.2 incrementiamo il requisito minimo per il PHP per far funzionare il software. Se vedi questo messaggio, controlla se il tuo hosting ha una qualche documentazione relativa all’aggiornamento della tua versione di PHP, oppure contatta o contattare l’amministratore del server / il team di supporto per ottenere assistenza su cosa fare.

    Ma io sto utilizzando PHP 5.6.3, non è più elevato di PHP 5.6.20?
    No, le versioni PHP e la maggior parte delle versioni software non seguono il modo in cui i decimali funzionano in matematica e così via. In questo caso, PHP 5.6.20 è superiore a PHP 5.6.3, perché 20 è superiore a 3.

    Non sono d’accordo con il punteggio di Health Check’s!
    Va bene! Ci sono comunque un paio di cose da tenere a mente:

    1. Health Check ti indirizzerà a ciò che gli sviluppatori principali di WordPress considerano lo scenario migliore per l’installazione di WordPress.
    2. Health Check non ti può leggere nella mente per determinare il contesto dietro le tue stesse decisioni.
    3. Non hai bisogno di ottenere un punteggio perfetto con Health Check.
    4. Questa è la tua installazione di WordPress, che puoi scegliere di eseguire come meglio credi.

    Il sito sta incontrando difficoltà tecniche.
    WordPress 5.2 introduce una nuova protezione dai siti in crash a causa di codice errato (noto anche come Schermata bianca della morte, o WSOD – White Screen of Death – in breve).
    Se il tuo sito si arresta in modo anomalo, viene visualizzato il messaggio precedente e viene inviata un’email all’amministratore del sito con la soluzione per accedere e disattivare il plugin o il tema che causa problemi; una volta fatto, il sito dovrebbe riprendere a funzionare come previsto.

    Cambiamenti nel Core

    Site Health Check
    Basata sulle caratteristiche introdotte nella 5.1, questa versione aggiunge due nuove pagine per aiutare a risolvere i problemi di configurazione comuni. Aggiunge anche uno spazio dove gli sviluppatori possono includere informazioni di debugging per i gestori del sito.

    Protezione dagli errori PHP
    Questo aggiornamento orientato per gli amministratori ti consentirà di correggere o gestire in modo sicuro gli errori fatali senza richiedere tempo per lo sviluppatore. Offre una migliore gestione della cosiddetta “schermata bianca della morte” e un modo per accedere alla modalità di ripristino, che mette in pausa plugin o temi che causano errori.

    Aggiornamenti per l’accessibilità
    Una serie di modifiche interagiscono per migliorare la consapevolezza contestuale e il flusso di navigazione della tastiera per coloro che utilizzano screen reader e altre tecnologie di assistenza.

    Nuove icone per la bacheca
    Tredici nuove icone includono Instagram, una serie di icone per BuddyPress e icone della Terra ruotate per l’inclusione globale. Trovali nella Bacheca e divertiti!

    Prima di pubblicare, assicurati di aver provato a iniziare eseguendo la procedura di risoluzione dei problemi descritta di seguito:

      • Svuotamento di tutti i plugin della cache che potresti avere in esecuzione, nonché delle cache del server e / o del browser. Non solo il browser, ma anche qualsiasi op cache o cache della rete di contenuti, così come Cloudflare. Questo risolverà molti strani problemi di JavaScript.
      • Svuotamento della cache dell’host gestito. L’hosting WP gestito ha spesso cache speciali. Se il tuo hosting ha uno strumento “Purge Varnish” o “Flush Memcache”, provalo. Puoi chiedere al tuo provider di scaricare memcache e Varnish per te, se necessario.
      • Salva nuovamente le impostazioni per i Permalink. In alcuni casi, abbiamo visto programmi di installazione di terze parti, come Softaculous, creare siti con regole leggermente errate nel file .htaccess. Mentre queste regole non sarebbero state un problema nelle versioni precedenti, in WordPress 5.0, avere queste regole errate può danneggiare le REST API. Il nuovo salvataggio dei permalink nella pagina Impostazioni-> Permalink in WordPress risolverà queste regole nel file .htaccess e, eventualmente, corregge errori “failed” nel nuovo editor.
      • Risoluzione dei problemi con il tuo browser. Il tuo browser può aiutarti a identificare problemi o conflitti JavaScript e questo articolo può aiutarti a fare quella diagnosi. Questo potrebbe aiutare a identificare anche i problemi dell’Editor visuale.
      • Assicurati di avere l’Editor visuale abilitato. Visita la pagina Utenti->Il tuo profilo. La prima opzione disabiliterà l’editor visuale. Assicurati che l’opzione sia disabilitata e salva le impostazioni del tuo profilo.
      • Disattivazione di tutti i plugin (sì, tutti) per vedere se questo risolve il problema. Se funziona, riattiva i plugin uno per uno fino a quando non tri il plugin (o i plugin) che causa i problemi. Se non puoi accedere alla bacheca di amministrazione, prova a reimpostare la cartella dei plugin tramite SFTP/FTP o PhpMyAdmin (Leggi “How to deactivate all plugins when you can’t log in to wp-admin” se hai bisogno di aiuto). Qualche volta che un plugin apparentemente inattivo possa causare problemi. Ricordati anche di disattivare i plugin nella cartella mu-plugins. Il metodo più facile è di rinominare la cartella in mu-plugins-old.
      • Passa al tema Twenty Nineteen per escludere problemi relativi al tema. Se non puoi accedere per cambiare i temi, puoi rimuovere la cartella del tema tramite SFTP/FTP in modo che ci sia solo twentynineteen. Questo forzerà il tuo sito a usarlo.
      • Aggiorna manualmente. Qualora anche questo non dovesse funzionare, scarica una copia nuova dell’ultimo file .zip della 5.0.* nel tuo computer (in alto a destra in questa pagina), e usalo per copiarlo nel sito. Devi cancellare le cartelle wp-admin e wp-includes sul tuo server (ATTENZIONE: non cancellare la directory wp-content directory o il tuo file wp-config.php). Leggi l’articolo Manual Update directions first
      • Se puoi installare i plugin, installa “Health Check”: https://wordpress.org/plugins/health-check/. Nella scheda per la risoluzione dei problemi, puoi cliccare sul pulsante per disattivare tutti i plugin e cambiare il tema, mentre sei ancora connesso, senza penalizzare i normali visitatori sul tuo sito.

    Se hai bisogno di creare un topic per il supporto, If you need to create a support topic, puoi fornire i dati di debug per i volontari di supporto visitando la sezione Site Health in Strumenti > Site Health > Info.

Stai visualizzando 6 risposte - dal 1 al 6 (di 6 totali)