Risposte nei forum create

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Chi ha creato la discussione gbuscemi

    (@gbuscemi)

    Ciao a tutti
    posto un nuovo aggiornamento, magari riesco con il vostro aiuto a venirne fuori.
    Dopo diversi tentativi, aggiornato sia wordpress che tutti i plug in, disattivati tutti i plug in e riattivati uno per volta, provato a impostare il php a 7.1 invece a 7.2 continuo ad avere sempre il medesimo problema
    controllato gli error log da HOST mi risulta:
    [Tue Mar 19 09:01:53.314516 2019] [proxy_fcgi:error] [pid 8055:tid 46916364670720] [client 185.175.213.94:40073] AH01071: Got error ‘PHP message: PHP Fatal error: Uncaught Error: Function name must be a string in /home/uo6zet0x/domains/scuoleisola.edu.it/public_html/wp-content/themes/pasw2015/github/vendor/Parsedown.php:894\nStack trace:\n#0 /home/uo6zet0x/domains/scuoleisola.edu.it/public_html/wp-content/themes/pasw2015/github/vendor/Parsedown.php(931): Parsedown->element(Array)\n#1 /home/uo6zet0x/domains/scuoleisola.edu.it/public_html/wp-content/themes/pasw2015/github/vendor/Parsedown.php(257): Parsedown->elements(Array)\n#2 /home/uo6zet0x/domains/scuoleisola.edu.it/public_html/wp-content/themes/pasw2015/github/vendor/Parsedown.php(48): Parsedown->lines(Array)\n#3 /home/uo6zet0x/domains/scuoleisola.edu.it/public_html/wp-content/themes/pasw2015/github/src/GitHub_Updater/Readme_Parser.php(52): Parsedown->text(‘The Cookie Law …’)\n#4 /home/uo6zet0x/domains/scuoleisola.edu.it/public_html/wp-content/themes/pasw2015/github/vendor/parse-readme.php(124): Fragen\\GitHub_Updater\\Readme_Parser->filter_text(‘The Cookie Law …’, true)\n#5 /home/uo6ze…\n’, referer: http://scuoleisola.edu.it/wp-login.php

    Per me quasi incomprensibile.
    Ho provato a scrivere a Marco Milesi il quale mi suggerisce di provare a cancellare il tema via ftp, operazione per me un tantino rischiosa non essendo proprio un esperto….
    Ho aperto un ticket ad Host ottenendo come risposta :

    “Buongiorno,
    per ora le consigliamo di mantenere la versione di PHP che non le genera problemi, purtroppo il nostro supporto tecnico non puo’ entrare così in profondità per capire quale dei componenti non è compatibile con la versione 7.1 o 7.2 di PHP.

    Di buona norma quello che consigliamo è :

    1. aggiornare il core di wordpress
    2. aggiornare tutti i plugin all’ultima versione
    3. verificare, singolarmente che i plugin siano tutti compatibili con la versione di PHP che si intende utilizzare
    4. verificare che il template in uso sia compatibile

    Tentare l’upgrade, se da errori, analizzare il file error log di apache per individuarne le cause, non sempre queste sono esplicite sul file. In caso il problema persista è necessario rivolgersi ad uno sviluppatore worpdress.

    QUINDI PRATICAMENTE SONO AD UN PUNTO MORTO …
    ALTRI SUGGERIMENTI?????
    Grazie sempre

    Chi ha creato la discussione gbuscemi

    (@gbuscemi)

    Grazie
    no il problema si presenta quando provo ad effettuare il login
    proverò ad eseguire i tuoi consigli…
    purtroppo non riesco proprio a capire
    al momento ho reimpostato il php a 5.6 e tutto funziona.

    Chi ha creato la discussione gbuscemi

    (@gbuscemi)

    Ciao @lucagrandicelli,
    purtroppo il problema persiste.
    Ho eseguito diverse prove
    ho disabilitato tutti i plugins e reimpostato il php a 7.2. Sembra che funzioni tutto ma dopo un ora circa il problema si ripresenta.
    Allora ho provato a disabilitare tutti i plugins e riabilitarli uno alla volta impostando il php nuovamente da 5.6 a 7.2 ma dopo aver riabilitato il plugin principali ( amministrazione trasparente, albo pretorio, Askimet, anac, contact form 7 ), per noi fondamentali, dopo un po il problema si ripresenta.
    NON CAPISCO DA COSA DIPENDA
    Ogni volta lo stesso problema, quello che è strano che a volte si presenta subito ed altre volte dopo 24 ore.
    Tutti i plugin sono aggiornati e WP è alla versione 5.1.1
    Ho provato anche a seguire le tue istruzioni e rinominare, temporaneamente, la cartella plugins… MA NULLA il problema persiste
    non so più cosa provare
    L’host ha il mio ticket ancora aperto senza risposta…
    🙁

    Chi ha creato la discussione gbuscemi

    (@gbuscemi)

    Ciao @lucagrandicelli
    sicuramente seguirò il tuo consiglio
    ho appena aggiornato il wordpress all’ultima versione 5.1 ed aggiornato tutti i plugin, al momento tutto bene. Adesso provo a passare il php da 5.6 a 7.1 (non 7.2 come la prima volta, chi sa che lo digerisca meglio).
    Cmq secondo te non era strano che l’errore 500 me lo dava solo ed esclusivamente quando provavo ad accedere come amministratore di WordPress mentre in fase di visualizzazione del sito o effettuando il login come altro utente (non amministratore) tutto andava bene?
    ti aggiorno…
    Grazie per la risposta.

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)