Risposte nei forum create

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Chi ha creato la discussione Liosite

    (@liosite)

    Grazie @luca21 ,
    ho letto e riletto nei limiti della mia capacità di comprendere intere pagine di “codex.wordpress.org”, ho seguito tutorial su YouTube e comprato corse su Udemy.
    Il risultato è stato pressocché ZERO.
    Il fatto che mi sta facendo impazzire è che il nuovo sito da me “costruito” funziona e il problema è solo nell’importare i dati (immagini e testi).
    I testi vanno tutti al loro posto ma le immagini no.
    Potrei riuscire a sistemarle credo ma questo porterebbe ad avere migliaia di immagini nella stessa cartella anno/mese in wp-content\uploads e non va.
    Anche con il contratto professional su serverplan, una cartella di quelle dimensioni non viene gestita.
    Qui purtroppo non è possibile postare degli screenshot, ma per me è una vera follia.
    Il post si apre perfettamente ed al posto della immagine mostra il solito simbolo di immagine mancante con il nome dell’immagine. Se prendo il link della immagine non mostrata nella pagina, sia usando il DX del mouse e il comando “Open in new tab, sia andando in “modifica” e selezionando l’immagine mancante nei dettagli ritrovo lo stesso link che messo nel browser porta all’immagine corretta (in locale) e in effetti nella cartella h**p://localhost/LioSite.com/wp-content/uploads/2017/08/Tatjana-Bek-Imperfezione.jpg l’immagine esiste.
    Ma allora perché nel post non viene visualizzata???
    Esiste qualche metodo per esportare testi e immagini dal sito online e reimportarli IDENTICI (stesse date, stesse cartelle) che funzioni?
    Non voglio mollare ma mi pare di incasinare sempre di più la situazione.
    Ed ogni volta butto tutto, reinstallo un nuovo WordPress, ricreo un nuovo database, ricreo le pagine importando i template che ho preparato, ricreo i CPT, le tassonomie etc, e poi …. nulla.
    Mi pare di capire che il database in MySql registri e ricordi ogni tentativo che io faccio di importare le immagini e al secondo tentativo anche se le immagini sono state cancellate, per lui sono presenti e quindi doppioni e quindi mi dice:

    Failed to import Media “William-Shakespeare-Ma-l’uomo,-l’uomo-orgoglioso”
    Failed to import Media “Erri-De-Luca-Gli-insorti-del-ghetto”
    Failed to import Media “Julio-Cortázar-Istruzioni-per-salire”

    or

    Media “Chiara” already exists.
    Media “Palazzo delle Tuileries” already exists.
    Media “Ribelle” already exists.
    Media “Insciallah” already exists.

    etc.
    Deve esistere una soluzione, ne sono certa.
    Pensavo di non potere essere in grado di creare un sito ed invece a quello sono riuscita ad arrivare in qualche modo, ma non riuscire a trasferire il contenuto del vecchio sito a quello nuovo non pensavo potesse essere un calvario simile.
    Ho anche pensato di fare (non so nemmeno esattamente cosa sia, ma nelle mie ricerche ne ho sentito parlare da molte parti) un “Redirect” tra il nuovo sito e il vecchio e poi proseguire con il materiale nuovo sul nuovo sito e man mano manualmente inserire le migliaia di vecchi post.
    Ma questo presupporrebbe lavorare live sul sito online e la cosa non mi piace per nulla.
    Anni al computer mi hanno ben insegnato a lavorare su copie e backup lasciando sempre integri gli originali, ma qui nn so che fare 🙁
    Se avete programmi da consigliare ve ne sarò grata.
    E comunque grazie per il tempo dedicatomi.

    Lio (vecchia stupida)

    • Questa risposta è stata modificata 5 anni, 1 mese fa da Liosite.
    Chi ha creato la discussione Liosite

    (@liosite)

    Ciao Luca21,

    grazie per la tua risposta. A Vancouver abita mia figlia ed è veramente un bellissimo posto, ma direi che tutto il Canada sia così, merita di sicuro lunghe visite.

    Sottodominio
    Non sapendo bene la differenza tra una cosa e l’altra e avendo solo capito che per averlo online senza che fosse “pubblica” bastava metterlo in una cartella, questo feci.
    In effetti sul sul Cpanel di Serverplan c’era una voce apposita per il sottodominio, ma il problema mia resta sempre lo stesso: non ho abbastanza conoscenze per fare le scelte giuste e anche cercando online non puoi imparare se non esiste un contraddittorio.
    Interpreti ma se lo fai sbagliando nessuno ti corregge 🙁
    Comunque ora farò un secondo tentativo usando la procedura del sotto dominio.

    Ora sto tentando una via differente, l’ennesima.
    Ho scoperto un plugin DeMomentSomTres Export che mi ha permesso di importare qui in locale (Xampp) le immagini esattamente come sul vecchio sito online, cioè mi ha ricostruito la gerarchia delle cartelle con gli anni e i mesi (almeno quelli che volevo importare dal 2010 ad oggi).
    Successivamente ho provato ad importare gli articoli del blog (il pacchetto più piccolo) tentando di eliminare il contemporaneo import delle immagini sperando così di ricreare il link tra la pagina e le immagini: sono riuscita al 50% nel senso che nonostante tutto si sono importate comunque molte immagini e sono divenute doppie ma avendo cmq le immagini corrette al posto corretto si è trattato solo di rimettere le cose a posto ed eliminare poi i doppioni.
    Ovviamente io non so cosa accada al database quando faccio queste operazioni, correggendo e sistemando: rovino tutto? Lo ingrosso a dismisura? Cosa potrei fare poi per ripulirlo da tutti i tentativi (ammesso che queste azioni vengano rilevate dal database)?
    Ora debbo provare per la prima delle due parti impegnative che sono 20 blocchi di database xml da 500 poesie l’una ma visto quello accaduto agli articoli debbo scoprire come fare per non importare assolutamente nulla delle immagini. Esiste l’opzione da spuntare ma pare non funzioni 🙁
    Ovviamente debbono rimanere le date originali ecc. Con l’importer di WP non credo sia fattibile (almeno con i post non sono riuscita), con WP All Import lo ho fatto e con le immagini comprese fa un lavoro perfetto, ma non riesco ad escluderle.
    Potrebbe forse essere dovuto al fatto che nell’originale le immagini erano contenute all’interno del post (poesia) e quindi il link alle immagini originali viene comunque inserito come text

    <content>
    <a href="http://www.liosite.com/wp-content/uploads/2017/03/Fernando-Pessoa-Quando-l-erba-crescera-sulla-mia-tomba.jpg"><img class="alignleft size-medium wp-image-28121" src="http://www.liosite.com/wp-content/uploads/2017/03/Fernando-Pessoa-Quando-l-erba-crescera-sulla-mia-tomba-300x225.jpg" alt="Fernando-Pessoa-Quando-l-erba-crescera-sulla-mia-tomba" width="300" height="225" /></a>Quando l'erba crescerà sulla mia tomba, sia lì il segno che mi si dimentichi del tutto. La Natura mai si ricorda, per questo è bella. E se si prova il bisogno morboso di "interpretare" L'erba verde sulla mia tomba, ..... </content>

    Ora riprovo per l’ennesima volta cercando di arrivare all’import ideale per potere creare il template ed usarlo anche per gli altri.
    E spero che i link si sistemino sulle immagini presenti: sarebbe un sogno!!

    Grazie e se avete suggerimenti per favore, io sono qui 🙂
    Lio

    Chi ha creato la discussione Liosite

    (@liosite)

    Grazie per la risposta e scusa il ritardo nel rispondere.
    Non so se possa avere un peso il fatto che online il sito sia fermo a WordPress 3.9.27 … e che tutti i plugins siano ovviamente ormai superati.
    Ovviamente qui in locale da due anni lavoro con la versione ultima di WP (5.1.1) e che il sito in locale non ha NULLA in comune con quello online salvo l’esatta ricostruzione dei link e cioè dei 3 CPT a cui i database si riferisce: blog, citazioni, poesie.
    Importare la parte di “testo” del database mi riesce perfettamente, i link nella versione di prova che ho messo on line in una cartella (stile sotto dominio) funzionano, il problema è solo quello delle immagini legate ai singoli “post” (poesie o citazioni) che non vengono scaricate creando le originali cartelle divise in anni e mesi. Una parte viene comunque scaricata ma messa tutta nella cartella del giorno in cui eseguo l’import, una parte non viene scaricata ma sembra esserci perché io vedo l’immagine che però non è nella cartella WP del sito in locale, ma viene richiamata come link dall’originale online!!
    Se per irsolvere il problema, scarico via ftp tutte le cartelle origina divise per mesi e anni della cartella uploads, non sono in grado di importarla in Media Library via WordPress. La colloco io manualmente al posto corretto ma ovviamente Ep non la legge e quindi non posso ripristinare i link saltati (anche attraverso un plugin).
    Hai ragione sul professionista…. ci ho già provato: ma qui in Canada fare sistemare un sito italiano direi sia impossibile.
    Ho provato a cercare qualcuno in Italia ma ovviamente nessuno accetterebbe di usare il frutto “grafico” dei miei due anni di lavoro per la creazione del tema.
    Sono ad un passo dalla meta (o almeno io mi illudo sia così) si tratta solo di importare il contenuto senza dovere reimmettere di nuovo manualmente trentamila post ed altrettante immagini.
    Le gallerie originali le ho eliminate creando tutto ex novo, quindi il problema resta nel far importare a WP la cartella uploads mantenendo invariato tutto (date e cartelle).
    Onestamente non voglio mollare il tema che ho creato del mio sito nuovo, ci ho lavorato giorni e giorni, portandomelo in ospedale durante le chemio, dimenticando ogni altra cosa pur di andare avanti e farlo, imparando il poco che ho imparato di html, php, css con corsi online: tutto perché volevo riuscire io a farlo.
    Comunque “autotutorial, grazie davvero per il tempo che mi hai dedicato: io continuo a provarci e se nn riuscirò inizierò a rimettere tutto manualmente.

    lio

    Chi ha creato la discussione Liosite

    (@liosite)

    Grazie Cristiano per la tua risposta e premetto di essere una vecchia incapace!
    La pagina che mi hai linkato la conoscevo e l’avevo religiosamente letta come mille altre ufficiali di WP o dei vari siti che fanno tuts per WP.
    Ho visualizzato anche decine di video su YouTube riguardanti la ma creazione di un sito staging in locale (con Xampp) e la successiva migrazione per riportarlo online.
    Non credo di fare errori in questi passaggi che credo di avere rifatto decine di volte ormai.
    Probabilmente l’errore si crea per un malintendimento da qualche parte visto che l’operazione che sto facendo io è mista: sposto in locale il contenuto di un sito online ma sulla struttura di un tema nuovo.
    Io faccio questi passi (o meglio questi sono quelli ultimi che sto facendo partendo da un sito locale WP completamente vergine senza alcun plugin, con un tema di base e solo con il database dei post):
    in locale:
    – creo un nuovo database
    – installo WP su Xampp
    online:
    – Via Filezilla scarico la cartella uploads con tutte le sotto cartelle
    – installo WP All Export che mi permette di scaricare i dati divisi per CPT (post, citazioni, poesie) (ho provato anche con l’export di WP e con una serie infinita di programmi ma l’unico con cui arrivavo al risultato “visivamente” corretto è questo)
    in locale:
    – inserisco la cartella uploads scaricata da Filezilla al posto della originale in questo specifico caso in J:\xampp\htdocs\wordpress\wp-content\uploads
    – installo WP all Import e inizio ad importare il database che NON ha bisogno di template (CPT) e cioè quello dei post (articoli) e tutto viene fatto dal programma.
    Questo programma ha una serie di opzioni tra cui lo scaricare in locale le immagini dal server O ignorare le immagini. Ho provato entrambe le alternative e nel primo caso (importando tutto) apparentemente sembra funzionare, aprendo i post ci sono le immagini e tutto pare OK. Queste immagini vengono pero’ importate in una differente cartella rispetto a quella dei link originali e cioè in J:\xampp\htdocs\wordpress\wp-content\uploads\wpallimport e da qui NON compaiono in Media Library.
    Allo stesso modo anche le immagini nella cartella Uploads (e relative sottocartelle) importata via FileZilla NON compare nella Media Library.
    Apparentemente tutto funziona ma il fatto è che mil sito in locale legge i e mostra le immagini che sono sul server remoto (quello dove c’è il sito pubblico)
    Mi rendo conto che la mia spiegazione sia incomprensibile, ma non so come spiegarmi meglio e sono stanca di sbattere la testa ovunque a causa di immagini che non vanno al loro posto.
    Io riesco a fare funzionare il nuovo sito ma solo con le immagini che si ritrovano tutte insieme nella cartella del mese e anno in cui faccio l’import dei vari CPT il che vuol dire 30 mila immagini insieme.
    Mi ero anche decisa a reimmettere tutte le immagini manualmente, una per una, dopo avere importato il solo database dei testi senza le immagini, ma anche in quel caso le immagini si ammasserebbero in una o due cartelle.
    Non mi pare di vedere da alcuna parte la possibilità di costringere WP a prendere le immagini dalle cartelle che io ho in portato in Uploads e che da Media Library nel back end non vengono viste.
    E’ solo questione di importare testi ed immagini esattamente come sono ma io non so come.
    E sono disperata!
    Grazie :'(

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)