{"id":21485,"date":"2019-02-06T17:34:28","date_gmt":"2019-02-06T16:34:28","guid":{"rendered":"https:\/\/it.wordpress.org\/support\/topic\/saltuario-503-bad-gateway\/"},"modified":"2019-02-06T17:34:28","modified_gmt":"2019-02-06T16:34:28","slug":"saltuario-503-bad-gateway","status":"publish","type":"topic","link":"https:\/\/it.wordpress.org\/support\/topic\/saltuario-503-bad-gateway\/","title":{"rendered":"Saltuario 503 Bad Gateway"},"content":{"rendered":"<p>Ho un problema da un po di tempo<br \/>\nho un sito che ultimamente ogni tanto cade ritornando errori di 503 Bad Gateway e Server Temporary Unvailable<br \/>\ntempo prima avevo riscontrato un errore php<br \/>\n<code>PHP Fatal error:  Allowed memory size of ... bytes exhausted (tried to allocate ... bytes)<\/code><br \/>\ne un&#8217;altro errore che si era raggiunto il limite di 30 come time<br \/>\nche ho risolto aumentando dal pannello plesk il limite memory_limit a 528M e mettendo nel wp-config.php il define(&#8216;WP_MEMORY_LIMIT&#8217;, &#8216;420M&#8217;);<br \/>\ndal pannello plesk avevo anche impostato il upload_max_filesize a 16M e max_execution_time e max_input_time a 800<br \/>\ne il sito sembrava essere tornato a posto e non comparivano pi\u00f9 errori nel debug.log<br \/>\nultimamente ho poi notato che non riuscivo a caricare i file con dimensione superiore a 2M anche se nel plesk dava il limite a 16M<br \/>\nho provato a fare un phpinfo e mi d\u00e0 memory_limit 128M\tupload_max_filesize 8M e max_execution_time e max_input_time impostati a 30 e 60, strano<br \/>\nho tolto tutti i plugin che potevo e corretto gli errori  che mi comparivano nel debug.log anche se c&#8217;erano solo notifiche e non errori gravi<\/p>\n<p>gli errori che vedo nel registro del plesk sono di questo tipo:<\/p>\n<pre><code>\nError\t\t\t17694#0: *3237138 upstream prematurely closed connection while reading response header from upstream\t\t\t\tErrore nginx\nError\t\t503\tPOST \/wp-admin\/?namespace=LPCurriculumRequest HTTP\/1.0\t\/wp-admin\/post.php?post=3304&amp;action=edit&amp;tab=content-drip&amp;message=1\tMozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko\/20100101 Firefox\/64.0\t1.33 K\tAccesso Apache\nError\t\t503\tPOST \/wp-admin\/admin-ajax.php?_fs_blog_admin=true HTTP\/1.0\t\/wp-admin\/plugins.php\tMozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko\/20100101 Firefox\/64.0\t1.33 K\tAccesso Apache\nError\t\t503\tPOST \/wp-admin\/admin-ajax.php?_fs_blog_admin=true HTTP\/1.0\t\/wp-admin\/post.php?post=3304&amp;action=edit&amp;tab=content-drip&amp;message=1\tMozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko\/20100101 Firefox\/64.0\t1.33 K\tAccesso Apache\nError\t\t503\tPOST \/wp-admin\/admin-ajax.php?action=wp_1_wc_privacy_cleanup&amp;nonce=386dfc3fb5 HTTP\/1.0\t\/wp-admin\/admin-ajax.php?action=wp_1_wc_privacy_cleanup&amp;nonce=386dfc3fb5\tWordPress\/4.9.9; http:\/\/\t1.33 K\tAccesso Apache\n<\/code><\/pre>\n<p>abbiamo chiesto spiegazioni al provider che ha detto che il problema non \u00e8 loro ma del sito che va in errore<br \/>\nho gi\u00e0 provato a fare tutte le verifiche del caso eliminato aggiornato e disattivato alcuni plugin, wordpress \u00e8 alla 4.9.9 non posso aggiornarlo ulteriormente per perdere la compatilit\u00e0 con altri plugin, ma niente ogni tanto il sito cade <\/p>\n<p>il problema \u00e8 che ora il sito \u00e8 diciamo di un hosting di prova con password (plugin Hide My Site) prima di spostare il sito su un nuovo hosting e quindi pubblicarlo ufficialmente dovrei risolvere questo problema vorrei sapere se ci sono altre operazioni che potrei fare.<\/p>\n<p>I plugin attivi sono:<br \/>\nQuery Monitor<br \/>\nAdd Featured Image Column<br \/>\nIvory Search<br \/>\nAdmin Menu Editor<br \/>\nAdvanced Cron Manager<br \/>\nCaldera Forms<br \/>\nAdmin Columns<br \/>\nCustom Content Shortcode<br \/>\nCustom CSS Pro<br \/>\nCustomVale<br \/>\nDuplicate Post<br \/>\nEmail Log<br \/>\nEmbed Any Document Plus<br \/>\nHide My Site<br \/>\nLearnPress &#8211; Certificates<br \/>\nLearnPress &#8211; Content Drip<br \/>\nLearnPress &#8211; Random Quiz<br \/>\nLearnPress<br \/>\nCustom Login Page Customizer<br \/>\nMultiple Roles<br \/>\nPayPal for WooCommerce<br \/>\nPlugin Notes Plus<br \/>\nPods Caldera Forms Processor<br \/>\nPods<br \/>\nProfile Builder<br \/>\nQuiz Next master<br \/>\nRedirection<br \/>\nEstratti Rich Text<br \/>\nWooCommerce Product Slider<br \/>\nBooster for WooCommerce<br \/>\nWooCommerce<br \/>\nWooDiscuz &#8211; WooCommerce Comments<br \/>\nYoast SEO<br \/>\nWP Menu Cart<br \/>\nWP Users Media<br \/>\nWPB WooCommerce Related Products Slider<br \/>\nCustom Product Tabs for WooCommerce<br \/>\nYITH WooCommerce Badge Management<br \/>\nYITH WooCommerce Multi Vendor Premium<\/p>\n<p>Grazie<\/p>\n","protected":false},"template":"","class_list":["post-21485","topic","type-topic","status-publish","hentry"],"jetpack_sharing_enabled":true,"_links":{"self":[{"href":"https:\/\/it.wordpress.org\/support\/wp-json\/wp\/v2\/topic\/21485","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/it.wordpress.org\/support\/wp-json\/wp\/v2\/topic"}],"about":[{"href":"https:\/\/it.wordpress.org\/support\/wp-json\/wp\/v2\/types\/topic"}],"version-history":[{"count":0,"href":"https:\/\/it.wordpress.org\/support\/wp-json\/wp\/v2\/topic\/21485\/revisions"}],"wp:attachment":[{"href":"https:\/\/it.wordpress.org\/support\/wp-json\/wp\/v2\/media?parent=21485"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}