Requisiti

Per eseguire WordPress raccomandiamo che il tuo host supporti:

  • PHP versione 7.2+ o superiore.
  • MySQL versione 5.6+ o superiore OPPURE MariaDB versione 10.0+ o superiore.
  • HTTPS supporto

E questo è tutto. Raccomandiamo Apache o Nginx in quanto sono server più robusti e ricchi di funzionalità per far girare WordPress, ma qualsiasi server che supporta PHP e MySQL andrà bene. Detto questo, non possiamo testare ogni ambiente possibile e ciascuno degli host presenti nella nostra pagina hosting supporta quanto sopra e di più senza problemi.

Nota: se ti trovi in un ambiente legacy (datato) in cui hai solo delle versioni di PHP e di MySQL precedenti, (o vecchie) ricordati che WordPress può lavorare anche con la versione di PHP 5.2.4+ e di MySQL 5.0+, però queste versioni hanno raggiunto la loro fine ufficiale del Ciclo di Vita, quindi come tali potrebbero esporre il tuo sito web (host) a vulnerabilità di sicurezza.

Chiedi

Ecco una richiesta di esempio che puoi inviare al tuo host; copia e incolla!

Sono interessato ad utilizzare il software web open-source WordPress <https://wordpress.org/> e vorrei sapere se l'hosting del mio account supporta quanto segue:

  • PHP 7.2 o versioni successive
  • MySQL 5.6 o superiore OPPURE MariaDB 10.0 o superiore
  • Nginx o Apache con modulo mod_rewrite
  • Supporto HTTPS

Grazie!

Non obbligatorio, ma consigliato per una maggiore sicurezza

L'hosting è più sicuro quando le applicazioni PHP, come WordPress, vengono eseguite (fatte girare) con l'account utente invece che con l'account predefinito del server condiviso. Informati, o chiedi all'host quali misure adotta per garantire la sicurezza dell'hosting dei propri account.