Better Plugin Compatibility Control

Descrizione

Better Plugin Compatibility Control rende facile per l’amministratore del blog il controllo della compatibilità di tutti i plugin installati. Il plugin aggiunge informazioni di compatibilità della versione alla pagina dei plugin per segnalare all’amministratore, a colpo d’occhio, se un plugin è compatibile con la versione WP corrente. Fino ad ora bisognava verificarlo sulla rispettiva pagina del plugin. L’amministratore può così decidere subito se disattivare un plugin non compatibile o meno.

Lingue Incluse:

  • Inglese
  • Tedesco (de_DE) (Ringraziamenti a me ;-))
  • Finlandese (fi_FI) (Ringraziamenti a C. Hellberg per aver contribuito alla lingua finnica)
  • Bielorusso (by_BY) (Ringraziamenti per aver contribuito alla lingua bielorussa a Marcis Gasuns)
  • Russo (ru_RU) (Ringraziamenti per aver contribuito alla lingua russa a iPower)
  • Uzbeco (uz_UZ) (Ringraziamenti per aver contribuito alla lingua uzbeca a Alexandra Bolshova)
  • Francese (fr_FR) (Ringraziamenti per aver contribuito alla lingua francese a tolingo translations)
  • Spagnolo (es_ES) (Ringraziamenti per aver contribuito alla lingua spagnola a nomeconsumas.org)
  • Ebraico (he_IL) (Ringraziamenti per aver contribuito alla lingua ebraica a Atar4U / https://profiles.wordpress.org/ahrale/)
  • Cinese Semplificato (zh_CN) (Ringraziamenti per aver contribuito alla lingua cinese semplificata a 斌果)
  • Italiano (it_IT) (Ringraziamenti per aver contribuito alla lingua italiana a venerdi)

Developer on Twitter

Cerchi altri plugins per WordPress? Visita www.schloebe.de/portfolio/

Licenza

Questo plugin è rilasciato sotto la GPL, puoi usarlo gratis sul tuo blog personale o commerciale.

Screenshot (schermate di esempio)

  • Le informazioni sulla compatibilità di versione vengono aggiunte sotto i titoli dei plugin.

Installazione

  1. Scarica il plugin e decomprimilo.
  2. Carica la cartella better-plugin-compatibility-control/ nella tua cartella /wp-content/plugins/ .
  3. Attiva il plugin dal tuo pannello amministratore di WordPress.
  4. Installazione terminata.

FAQ

Perchè manca questo o quello per migliorare l’interfaccia del plugin?

Se hai dei suggerimenti per favore fammelo sapere inviandomi una e-mail o sui forum di wp.org .

Storia?

Visita il sito web ufficiale per le ultime informazioni su questo plugin.

Dove posso trovare maggiori informazioni?

Visita il sito ufficiale per le ultime novità su questo plugin.

Recensioni

5 Dicembre 2018
Does what is says, displays the WordPress version compatibility for each plugin on your site. It's easy to view the version info. However, there are some instances when and older WordPress version is displayed, even though the plugin is compatible with the most current version of WordPress. When you notice a plugin has an older WordPress version displayed, select the "View Details" option for each plugin to confirm the info with the repository.
14 Agosto 2017
Not accurate in a lot of cases, checks readme files, not WordPress Depository... What's the point if the info cannot be trusted to be accurate...
8 Aprile 2017
Needs to have less bugs in Query Monitor plugin for me to be able to let it up all day, but it's a must have plugin. No problem in letting it ON.
6 Marzo 2017
The version information provided by this plug-in does not always match the information you get from the repository. And even if a plug-in does not officially support your WordPress version it might still work fine. So use "Better Plugin Compatibility Control" with care and common sense.
Leggi tutte le recensioni di 18

Crediti e riconoscimenti

“Better Plugin Compatibility Control” è un software open source. Le persone che hanno contribuito allo sviluppo di questo plugin sono indicate di seguito.

Collaboratori

“Better Plugin Compatibility Control” è stato tradotto in 1 lingua. Grazie ai traduttori per i loro contributi.

Traduci “Better Plugin Compatibility Control” nella tua lingua.

Ti interessa lo sviluppo?

Esplora il Codice segui il Repository SVN iscriviti al Log delle Modifiche. Puoi farlo tramite RSS con un lettore di feed.

Changelog (registro delle modifiche)

5.3.0

  • Salto di versione
  • WordPress 5.3 compatibility

5.2.0.5

  • Fixed a rare but annoying Undefined property error (thanks divavocals & pchenriques!)

5.2.0

  • Salto di versione
  • WordPress 5.2 compatibility

5.1.0

  • Salto di versione
  • WordPress 5.1 compatibility

5.0.0

  • Salto di versione
  • WordPress 5.0 compatibility

4.9.5

  • Salto di versione
  • Minor bug fixes
  • PHP 7.2 compatibility

4.9.0

  • Compatibilità con WordPress 4.9

4.8.0

  • Compatibilità con WordPress 4.8

4.7.0.1

  • Corretto un errore in Undefined property: stdClass::$tested

4.7.0

  • Compatibilità con WordPress 4.7
  • Compatibilità con PHP 7

4.6.1

  • Corretto un piccolo errore nella colorazione della versione

4.6.0

  • Salto di versione

4.5.0

  • Aggiunta localizzazione in italiano (Grazie a venerdi!)
  • Salto di versione

4.4.0.2

  • Miglioramenti del codice e di compatibilità (grazie a AlfonsBerger!)

4.4.0.1

  • Preparato per la localizzazione su wp.org
  • Miglioramenti visivi (grazie Demetrio Mendozzi!)
  • Corretto errore di battitura nel readme.txt (grazie Demetrio Mendozzi!)

4.4.0

  • Salto di versione

4.1.1

  • Aggiunta localizzazione in ebraico (Grazie a Atar4U)

4.0.999

  • Salto di versione
  • Pulizia del codice e miglioramenti

3.8.1.10

  • Cambiata la gestione delle indicazioni di compatibilità della versione (ad esempio, invece di indicare 3.8.1 come incompatibile su una installazione 3.8 , ora indica tutte le versioni 3.8.x come compatibili, quindi se un plugin supporta una versione principale, si presume supporti anche tutti le versioni minori) (proposto da GermanKiwi!)

3.8.1.5

  • Ridotti i requisiti minimi di WP del plugin
  • Migliorata la compatibilità multisito

3.8.1.1

  • Corretta la lunga riga di testo inutile che appariva, in alcuni casi, nelle informazioni di versione

3.8.1

  • Pulizia del codice

3.8

  • Salto di versione
  • Pulizia del codice e miglioramenti

3.6

  • Pulizia del codice e miglioramenti

3.5.1

  • Salto di versione

3.5

  • Readme.txt aggiornato per essere più aderente al readme.txt standard
  • Spostati gli screenshots fuori dal pacchetto nella cartellla assets/

3.4.1

  • Aggiornamento di manutenzione (Moltissime grazie a Gary Gale!)

3.4

  • Aggiornamento di manutenzione

3.3

  • Aggiornamento di manutenzione

1.1.1

  • Ora combina le informazioni tra il file readme.txt locale ed i dati del repository WordPress, preferendo i dati locali
  • Supporto multisito

1.1

  • Nuovo, versione minima impostata a WP 2.8
  • Analisi delle informazioni di compatibilità migliorata e più aggiornata grazie all’utilizzo delle plugins_api al posto dell’analisi del file readme locale del plugin
  • Pulizia del codice

1.0.1

  • Compatibilità con WordPress 2.8

1.0

  • Plugin rilasciato